PKGBUILD 2.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475
  1. # Maintainer: Antonio Rojas <arojas@archlinux.org>
  2. pkgname=qt5-webkit-print
  3. _qtver=5.212.0-alpha2
  4. pkgver=${_qtver/-/}
  5. # pkgver=5.212.0-alpha2
  6. pkgrel=1
  7. arch=(x86_64)
  8. url='https://github.com/annulen/webkit/wiki'
  9. license=(GPL3 LGPL3 FDL custom)
  10. pkgdesc='Classes for a WebKit2 based implementation and a new QML API (maintained fork) (patched with pdf scale and background fixes)'
  11. depends=(qt5-location qt5-sensors qt5-webchannel libwebp libxslt libxcomposite gst-plugins-base hyphen)
  12. makedepends=(cmake ruby gperf python2 qt5-doc qt5-tools)
  13. optdepends=('gst-plugins-good: Webm codec support')
  14. conflicts=(qt5-webkit)
  15. provides=(qt5-webkit)
  16. source=("https://github.com/annulen/webkit/releases/download/qtwebkit-$_qtver/qtwebkit-$_qtver.tar.xz"
  17. qt5-webkit-pdf_scaling.patch qt5-webkit-solid_background_PDF.patch)
  18. sha256sums=('f8f901de567e11fc5659402b6b827eac75505ff9c5072d8e919aa306003f8f8a'
  19. '3118595e764bec08960518c07eb5c321d7195b23adc634ba7a50987aeec642b0'
  20. '339876e8dfdaabdc974d2b2f095d85691d339aef16abe97b472268dae462d0cf')
  21. prepare() {
  22. mkdir -p build
  23. cd qtwebkit-$_qtver
  24. # aleray fixes (https://github.com/annulen/webkit/compare/qtwebkit-stable...aleray:ospkit2)
  25. patch -p1 -i ../qt5-webkit-pdf_scaling.patch
  26. patch -p1 -i ../qt5-webkit-solid_background_PDF.patch
  27. sed -e 's|-Wundef|-Wundef -Wno-expansion-to-defined|' -i Source/cmake/WebKitHelpers.cmake
  28. }
  29. build() {
  30. cd build
  31. cmake ../qtwebkit-$_qtver \
  32. -DCMAKE_INSTALL_PREFIX=/usr \
  33. -DCMAKE_BUILD_TYPE=Release \
  34. -DPORT=Qt \
  35. -DENABLE_TOOLS=OFF
  36. # -DCMAKE_INSTALL_PREFIX:PATH=/usr/local \
  37. # -DVMIME_INSTALL_LIBDIR=/usr/local/lib \
  38. # -DENABLE_WEBKIT2=OFF \
  39. # -DENABLE_VIDEO=OFF \
  40. # -DENABLE_WEB_AUDIO=OFF \
  41. # -DENABLE_GEOLOCATION=OFF \
  42. # -DENABLE_IOS_AIRPLAY=OFF \
  43. # -DENABLE_MINIBROWSER=OFF \
  44. # -DENABLE_NOTIFICATIONS=OFF \
  45. # -DENABLE_REMOTE_INSPECTOR=OFF \
  46. # -DENABLE_SPEECH_SYNTHESIS=OFF \
  47. # -DENABLE_TOUCH_EVENTS=OFF \
  48. # -DENABLE_TOUCH_SLIDER=OFF \
  49. # -DENABLE_TOUCH_ICON_LOADING=OFF \
  50. # -DENABLE_DEVICE_ORIENTATION=OFF \
  51. # -DENABLE_GAMEPAD=OFF \
  52. # -DENABLE_MEDIA_CAPTURE=OFF \
  53. # -DENABLE_VIBRATION=OFF
  54. make
  55. }
  56. package() {
  57. # mkdir -p "$pkgdir/etc/ld.so.conf.d"
  58. # install -Dm644 lib64-libriis.conf "$pkgdir/etc/ld.so.conf.d/lib64-libriis.conf"
  59. cd build
  60. make DESTDIR="$pkgdir" install
  61. # mv "$pkgdir"/usr/local/lib64 "$pkgdir"/usr/local/lib
  62. install -d "$pkgdir"/usr/share/licenses
  63. ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}
  64. }