123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475 |
- pkgname=qt5-webkit-print
- _qtver=5.212.0-alpha2
- pkgver=${_qtver/-/}
- pkgrel=1
- arch=(x86_64)
- url='https://github.com/annulen/webkit/wiki'
- license=(GPL3 LGPL3 FDL custom)
- pkgdesc='Classes for a WebKit2 based implementation and a new QML API (maintained fork) (patched with pdf scale and background fixes)'
- depends=(qt5-location qt5-sensors qt5-webchannel libwebp libxslt libxcomposite gst-plugins-base hyphen)
- makedepends=(cmake ruby gperf python2 qt5-doc qt5-tools)
- optdepends=('gst-plugins-good: Webm codec support')
- conflicts=(qt5-webkit)
- provides=(qt5-webkit)
- source=("https://github.com/annulen/webkit/releases/download/qtwebkit-$_qtver/qtwebkit-$_qtver.tar.xz"
- qt5-webkit-pdf_scaling.patch qt5-webkit-solid_background_PDF.patch)
- sha256sums=('f8f901de567e11fc5659402b6b827eac75505ff9c5072d8e919aa306003f8f8a'
- '3118595e764bec08960518c07eb5c321d7195b23adc634ba7a50987aeec642b0'
- '339876e8dfdaabdc974d2b2f095d85691d339aef16abe97b472268dae462d0cf')
- prepare() {
- mkdir -p build
- cd qtwebkit-$_qtver
- patch -p1 -i ../qt5-webkit-pdf_scaling.patch
- patch -p1 -i ../qt5-webkit-solid_background_PDF.patch
- sed -e 's|-Wundef|-Wundef -Wno-expansion-to-defined|' -i Source/cmake/WebKitHelpers.cmake
- }
- build() {
- cd build
- cmake ../qtwebkit-$_qtver \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DPORT=Qt \
- -DENABLE_TOOLS=OFF
- make
- }
- package() {
- cd build
- make DESTDIR="$pkgdir" install
- install -d "$pkgdir"/usr/share/licenses
- ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}
- }
|