Browse Source

fixed bad pkgver and removed obsolete patches

Bachir Soussi Chiadmi 6 years ago
parent
commit
755d82a9c6
5 changed files with 4 additions and 103 deletions
  1. 1 7
      .SRCINFO
  2. 3 6
      PKGBUILD
  3. 0 38
      qt5-webkit-icu59.patch
  4. 0 40
      qt5-webkit-ng-functional.patch
  5. 0 12
      qt5-webkit-ng-gcc7.patch

+ 1 - 7
.SRCINFO

@@ -1,5 +1,5 @@
 # Generated by mksrcinfo v8
-# Mon Jun 26 10:11:59 UTC 2017
+# Mon Jun 26 10:38:03 UTC 2017
 pkgbase = qt5-webkit-print
 	pkgdesc = Classes for a WebKit2 based implementation and a new QML API (maintained fork) (patched with pdf scale and background fixes)
 	pkgver = 5.212.0alpha2
@@ -28,15 +28,9 @@ pkgbase = qt5-webkit-print
 	provides = qt5-webkit
 	conflicts = qt5-webkit
 	source = https://github.com/annulen/webkit/releases/download/qtwebkit-5.212.0-alpha2/qtwebkit-5.212.0-alpha2.tar.xz
-	source = qt5-webkit-icu59.patch
-	source = qt5-webkit-ng-gcc7.patch
-	source = qt5-webkit-ng-functional.patch
 	source = qt5-webkit-pdf_scaling.patch
 	source = qt5-webkit-solid_background_PDF.patch
 	sha256sums = f70fea4623a0f1df6ec535358f9c431d6ead9c04742a85258aaabcd0805d2719
-	sha256sums = e1306e696ad7125fa00083aa966be0ea6fe6de555c9e1d119957f208f258edfe
-	sha256sums = 58ecbd8708f5afe4e974fdcd6c1f32fea61ccc55dc9bb711768f2d0da6963fb8
-	sha256sums = c85344edcc23930c0190b2f8ec3847bf8bdbbf7f1d4fa877c502e354e5f4233e
 	sha256sums = 3118595e764bec08960518c07eb5c321d7195b23adc634ba7a50987aeec642b0
 	sha256sums = 339876e8dfdaabdc974d2b2f095d85691d339aef16abe97b472268dae462d0cf
 

+ 3 - 6
PKGBUILD

@@ -15,18 +15,15 @@ optdepends=('gst-plugins-good: Webm codec support')
 conflicts=(qt5-webkit)
 provides=(qt5-webkit)
 source=("https://github.com/annulen/webkit/releases/download/qtwebkit-$_qtver/qtwebkit-$_qtver.tar.xz"
-        qt5-webkit-icu59.patch qt5-webkit-ng-gcc7.patch qt5-webkit-ng-functional.patch qt5-webkit-pdf_scaling.patch qt5-webkit-solid_background_PDF.patch)
+        qt5-webkit-pdf_scaling.patch qt5-webkit-solid_background_PDF.patch)
 sha256sums=('f70fea4623a0f1df6ec535358f9c431d6ead9c04742a85258aaabcd0805d2719'
-            'e1306e696ad7125fa00083aa966be0ea6fe6de555c9e1d119957f208f258edfe'
-            '58ecbd8708f5afe4e974fdcd6c1f32fea61ccc55dc9bb711768f2d0da6963fb8'
-            'c85344edcc23930c0190b2f8ec3847bf8bdbbf7f1d4fa877c502e354e5f4233e'
             '3118595e764bec08960518c07eb5c321d7195b23adc634ba7a50987aeec642b0'
             '339876e8dfdaabdc974d2b2f095d85691d339aef16abe97b472268dae462d0cf')
 
 prepare() {
   mkdir -p build
 
-  cd qtwebkit-$pkgver-alpha
+  cd qtwebkit-$_qtver
 # Fix build with ICU 59 (PLD linux)
   patch -p1 -i ../qt5-webkit-icu59.patch
 # Fix build with GCC 7
@@ -42,7 +39,7 @@ prepare() {
 build() {
   cd build
 
-  cmake ../qtwebkit-$pkgver-alpha \
+  cmake ../qtwebkit-$_qtver \
     -DCMAKE_INSTALL_PREFIX=/usr \
     -DCMAKE_BUILD_TYPE=Release \
     -DPORT=Qt \

+ 0 - 38
qt5-webkit-icu59.patch

@@ -1,38 +0,0 @@
---- qtwebkit-opensource-src-5.5.1/Source/JavaScriptCore/API/JSStringRef.h.orig	2015-10-13 06:37:10.000000000 +0200
-+++ qtwebkit-opensource-src-5.5.1/Source/JavaScriptCore/API/JSStringRef.h	2017-04-24 12:26:42.495345570 +0200
-@@ -32,6 +32,7 @@
- #include <stdbool.h>
- #endif
- #include <stddef.h> /* for size_t */
-+#include <uchar.h>
- 
- #ifdef __cplusplus
- extern "C" {
-@@ -43,7 +44,7 @@
- @typedef JSChar
- @abstract A Unicode character.
- */
--    typedef unsigned short JSChar;
-+    typedef char16_t JSChar;
- #else
-     typedef wchar_t JSChar;
- #endif
---- qtwebkit-opensource-src-5.5.1/Source/WebKit2/Shared/API/c/WKString.h.orig	2015-10-13 06:37:12.000000000 +0200
-+++ qtwebkit-opensource-src-5.5.1/Source/WebKit2/Shared/API/c/WKString.h	2017-04-24 12:27:33.432011867 +0200
-@@ -31,6 +31,7 @@
- #ifndef __cplusplus
- #include <stdbool.h>
- #endif
-+#include <uchar.h>
- 
- #ifdef __cplusplus
- extern "C" {
-@@ -38,7 +39,7 @@
- 
- #if !defined(WIN32) && !defined(_WIN32) \
-     && !((defined(__CC_ARM) || defined(__ARMCC__)) && !defined(__linux__)) /* RVCT */
--    typedef unsigned short WKChar;
-+    typedef char16_t WKChar;
- #else
-     typedef wchar_t WKChar;
- #endif

+ 0 - 40
qt5-webkit-ng-functional.patch

@@ -1,40 +0,0 @@
---- webkit-qtwebkit-tp5/Source/JavaScriptCore/inspector/InspectorBackendDispatcher.h.orig	2017-06-01 06:14:55.587195469 +0000
-+++ webkit-qtwebkit-tp5/Source/JavaScriptCore/inspector/InspectorBackendDispatcher.h	2017-06-01 06:15:23.040491577 +0000
-@@ -32,6 +32,7 @@
- #include <wtf/Optional.h>
- #include <wtf/RefCounted.h>
- #include <wtf/text/WTFString.h>
-+#include <functional>
- 
- namespace Inspector {
- 
---- webkit-qtwebkit-tp5/Source/WebCore/css/CSSValue.h.orig	2017-06-01 07:48:18.099623726 +0000
-+++ webkit-qtwebkit-tp5/Source/WebCore/css/CSSValue.h	2017-06-01 07:48:41.542925091 +0000
-@@ -27,6 +27,7 @@
- #include <wtf/RefCounted.h>
- #include <wtf/RefPtr.h>
- #include <wtf/TypeCasts.h>
-+#include <functional>
- 
- namespace WebCore {
- 
---- webkit-qtwebkit-tp5/Source/WebCore/css/StyleSheetContents.h.orig	2017-06-01 08:33:31.792577087 +0000
-+++ webkit-qtwebkit-tp5/Source/WebCore/css/StyleSheetContents.h	2017-06-01 08:33:44.715892348 +0000
-@@ -30,6 +30,7 @@
- #include <wtf/Vector.h>
- #include <wtf/text/AtomicStringHash.h>
- #include <wtf/text/TextPosition.h>
-+#include <functional>
- 
- namespace WebCore {
- 
---- webkit-qtwebkit-tp5/Source/WebCore/loader/ResourceLoader.h.orig	2017-06-01 09:47:50.463011889 +0000
-+++ webkit-qtwebkit-tp5/Source/WebCore/loader/ResourceLoader.h	2017-06-01 09:48:21.976300680 +0000
-@@ -35,6 +35,7 @@
- #include "ResourceRequest.h"
- #include "ResourceResponse.h"
- #include <wtf/Forward.h>
-+#include <functional>
- 
- namespace WTF {
- class SchedulePair;

+ 0 - 12
qt5-webkit-ng-gcc7.patch

@@ -1,12 +0,0 @@
-Index: /trunk/Source/JavaScriptCore/runtime/JSArrayBufferView.h
-===================================================================
---- trunk/Source/JavaScriptCore/runtime/JSArrayBufferView.h	(revision 211433)
-+++ trunk/Source/JavaScriptCore/runtime/JSArrayBufferView.h	(revision 211434)
-@@ -168,5 +168,5 @@
-     void neuter();
-     
--    void* vector()
-+    void* vector() const
-     {
-         return m_vector.getPredicated(
-             this,